Ошибка в JakoDorgen PRO (крякнутая версия)

Плюсануть
Поделиться
Класснуть

Собственно помимо пинания хуя я занимаюсь дорами. Вернее опять начал, был долгий простой. У меня уже стоит виртуальная машина с Windows 7 (я же убунтовод, на самом компьютере венды нет, только на виртуалке), там я и собирался запустить JakoDorgen PRO. Да да, запускал крякнутую версию.

Ну и, собственно, после загрузки архива с доргеном я с довольным видом запускаю JakoDorgen_PRO_run.exe, а тут нежданчик, ошибка. Погуглил - нужно установить NET Framework. Установил, запускаю - нихуя, ошибка. Перезагрузился - та же песня.

Причём ошибка странная, за 10 лет использования венды первый раз такая. Что то связанное с JIT-отладчиком, уже не вспомню. Гуглил как править ошибку - безуспешно, ничего нет.

И тут на нулледе случайно нашёл решение. Проблема была в том, что у меня система x64 и нужно заставить .NET-приложения запускаться в режиме x86. Для этого нужно выполнить следующую команду:

%WINDIR%\Microsoft.NET\Framework64\v2.0.50727\Ldr64.exe setwow

Папка "v2.0.50727" в пути может отличаться в зависимости от установленной версии NET Framework.

Всё, теперь запускаем JakoDorgen_PRO_run.exe (стоит поставить эмуляцию Windows XP SP3 и запускать от админа), всё должно работать.

Последнее изменение записи: 28.12.2015 | Рубрика: Работа | Метки: ,
Плюсануть
Поделиться
Класснуть